Some users cannot login to Renaissance Growth Platform (RGP)
Incident Report for Renaissance Learning
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 21:48 CST
Identified
Some users who login to Renaissance products using the Renaissance Growth Platform (RGP) cannot login. The issue has been identified and we are in the process of resolving.
Posted Jan 14, 2025 - 12:13 CST
This incident affected: Renaissance Growth Platform (RGP).