Intermittent Login Issues with eduCLIMBER
Incident Report for Renaissance Learning
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 18:12 CST
Update
We are continuing to investigate this issue.
Posted Dec 14, 2023 - 13:31 CST
Investigating
We are currently investigating where some customers are having trouble logging in to the eduCLIMBER application.
Posted Dec 14, 2023 - 10:18 CST
This incident affected: eduCLIMBER.