Unable to login to the eduClimber application.

Incident Report for Renaissance Learning

Resolved

This incident has been resolved.
Posted Nov 14, 2023 - 08:52 CST

Investigating

Users are currently unable to login to the eduCLIMBER application. We are currently investigating the cause.
Posted Nov 14, 2023 - 08:48 CST
This incident affected: eduCLIMBER.