Fastbridge - Site currently inaccessible

Incident Report for Renaissance Learning

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 11:46 CDT

Update

Site is accessible and will continue to be monitored.
Posted Apr 23, 2025 - 20:44 CDT

Monitoring

The site is now back up and the team is monitoring and verifying the fix.
Posted Apr 23, 2025 - 20:05 CDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 23, 2025 - 19:25 CDT

Identified

We are currently investigating this issue. A cause has been identified.
Posted Apr 23, 2025 - 19:24 CDT
This incident affected: FastBridge.