Degraded Performance
Incident Report for Renaissance Learning
Resolved
We have resolved the issue, thank you for your patience.
Posted Dec 19, 2023 - 09:52 CST
Identified
Some users have reported degraded system performance. Our engineering team is aware of the issue and will be putting a fix in place shortly. We expect about 10 minutes of downtime while this happens. Thank you for your patience while we work to resolve this issue.
Posted Dec 19, 2023 - 09:16 CST
This incident affected: SchoolCity.