FastBridge - Partial Outage

Incident Report for Renaissance Learning

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 09:38 CDT

Identified

The issue has been identified, testing to be done Thursday and Friday. Fix to be deployed over the weekend.
Posted Sep 11, 2025 - 09:59 CDT
This incident affected: FastBridge.