Renaissance Next for Teachers Slow Load Times
Incident Report for Renaissance Learning
Resolved
Load times have normalized.
Posted Sep 04, 2024 - 16:30 CDT
Monitoring
We experienced an issue on the Renaissance Next platform where some users may have experienced slower than normal load times. A fix has already been put in place and we are starting to see load times begin to normalize. We are continuing to monitor the situation.
Posted Sep 04, 2024 - 11:11 CDT
This incident affected: Renaissance Next for Teachers.