SchoolCity Database Performance

Incident Report for Renaissance Learning

Resolved

The performance issues reported earlier today have been resolved. As of approximately 12:11 PM CST, all services — including login and student workflows — have been restored and are operating normally.


We apologize for the disruption and thank you for your patience. If you continue to experience any issues, please contact support.
Posted Aug 28, 2026 - 13:42 CDT

Investigating

We are aware that some districts began experiencing slow performance in SchoolCity starting at approximately 9:00 AM CST today. Earlier reports of login difficulties have been resolved.

Our team is actively investigating the cause of the slowness and is working to restore full performance as quickly as possible. We will provide updates as more information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Aug 28, 2026 - 12:19 CDT
This incident affected: SchoolCity.